Anaconda-glibc版本问题

在服务器上安装最新的Anaconda-2.5时提示”/anaconda/bin/python: /lib64/libc.so.6: version `GLIBC_2.7’ not found (required by /anaconda/bin/python)”,表明新版本的Anaconda需要的Glibc版本>=2.7。
通过搜索,发现github上有人说到

Anaconda 5 no longer supports CentOS 5 / glibc 2.5 as the baseline. It has moved to CentOS 6 / glibc 2.12. You’ll need to stick with conda < 4.3.27, which will keep you on the old “defaults” channel. The new defaults channel includes https://repo.continuum.io/pkgs/main, and this is where all software will be compatible with glibc 2.12 and up.

to prevent conda from updating itself, you can do:
conda config —set auto_update_conda false
at the terminal

也就是Anaconda-2.5之后便不再支持centos5,经测试发现 centos5 可以安装Anaconda-2.4.4.0。